cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Welcome REI Co-op Members!
We're glad you're here. If you can't access the Co-op Members section of the community,
click here for instructions on how to join the section that's just for you.

How to: Link your REI membership to your online account (and earn the Member badge)

Want to show off your co-op member status with a cool member badge here in the community?! And be able to join the member-only section of Conversations?! To earn it, you just need to link your REI membership to your online account. To do this, follow these steps: 

  • On REI.com, click on “Sign in” and enter your email address and password; if you are already signed in, click on “My Account” instead 
  • Once you are signed in, click on “My account,” then click “Link your REI member number” 
  • On the next page, enter your member number (or use the look-up tool if you don’t know it); if you’re not already a co-op member, you can easily follow the steps to join! 

badge-founding-member.png

 

At REI, we believe time outside is fundamental to a life well lived.
16 Replies

I do not appear to have the "Link account" option in the My Account screen, it does show my member number in the top left area, so I presume that would indicate my account is linked; however I still det access denied when I try to go to the members only section.

I am having the same issue as thatbenguy - the "link account" option does not appear under My Account. 

Same issue as thatbenguy, just not seeing what's being described by REI above.

ditto

If anyone is having a hard time seeing the Co-op Member section but is confident your member number is attached to your online REI account, try signing out and signing back in. We've heard that this quick action is fixing the issue for some, and triggers the member badge, member role and access to the member-only section! @bones @mels @thatbenguy @buster 

At REI, we believe time outside is fundamental to a life well lived.

So logging out and back in did the trick! Didn't have to use my account number at all. It automatically gave the badge once back in conversations.

Flagra

Seems like there's an issue with the Community site and Firefox. No matter what I tried on Firefox it would just kick me back to the rei.com main page, but when I tried with Chrome it worked.

That worked for me, thanks!

“Buddha, Jesus, and Reese Witherspoon all went to the desert to seek wisdom.”
― Florence Williams

Yes, fixed it for me.  I should've known to try the "unplug, wait 30 seconds, plug back in" method.  Thanks!